Posts: 2
Joined: 11 Jun 2008
hi, i discovered recently antiX and i love it. I try to install in old '98 laptop Pentium MMX 233 wiht 32 MB RAM but without success. Directly with the cd is simply freeze and i tried too"Boot from iso on hard-disk" and start ok but i have that after:

"Booting MEPIS Linux Removable Media"
"looking for MEPIS Linux"............................Building ramdisk directories...done
Starting root filesystem...

and here the error

Starting pid 10444, console /dev/tty1: '/etc/init.d/rcS'
Bummer, could not run '/etc/init.drcS': No such file or directory
Please press Enter to activate this console.

and after nothing... each time after ENTER.. the same thing...

i love linux but i don't know internally.. so.. can your help me !!?? thanks

or is not possible to install in this machine?? thanks

Posts: 5,955
Site Admin
Joined: 11 Sep 2007
Hi luis.

How are you booting from iso? What entry do you have in your boot/grub for fromiso? The message you are getting is usually when there is some problem with the grub entry not being correct.

However, getting antiX to boot as a live cd and install with only 32MB RAM is unlikely I think. Someone managed to get antiX-M6.5 to run (installed) with only 32MB RAM. The person added some RAM to the box, installed antiX and then removed the extra RAM.

You might be able to do this. If you can I would suggest getting some more RAM, antiX works very well with 96MB RAM, ok with 64 MB RAM, less is IMO painful.
Posts: 2
Joined: 11 Jun 2008
thanks for the fast reponse
i followed the installation tips in the website"booting from iso on hd". My grub is like that

title antiX

kernel (hd0,1)/antiX/vmlinuz vga=normal fromhd=/dev/hda2 fromiso=/antiX/antiX-6.5.iso en xres=800x600

initrd (hd0,1)/antiX/initrd.gz


I tried changing hda2--> sda2 but the same problem and adding in the beginning
root (hd0,1)

and about more RAM... the problem is that is a toshiba satellite and more memory is expensive (i can't understand !!) and investing (about money) in this laptop is without sens; investing my time there's no problem, i learning... and nobody of my friends are that memory (memory"toshiba").. and in the"used commerce" is really difficult. but it is not possilble i will continue with dsl (with k2.4.26) or/and Vector 5.1 STD (k2.6.10) like now.
Posts: 8
Joined: 27 Sep 2010

18 Oct 2010, 05:33 #4

This an old thread, I know. I managed to get an old industrial pc to boot into text mode by installing th os on a uptodate box, ripping out the hd and reinstalling it in the industrial pc. It was a 2.4 based distro, that I don't remember. I still have the industrial pc (runs dos at the time being) and will try with antix soon. I will report back.

greets chris